PRA 16.0.0.2 problems

PRA, BeqMoni, Theremino, Fitzpeaks and beyond!
Post Reply
User avatar
Geoff
Posts: 98
Joined: 01 May 2015, 12:21
Location: Marathon County, Wisconsin
Contact:

PRA 16.0.0.2 problems

Post by Geoff » 19 Jul 2017, 03:03

I'm not sure if anyone else is having problems, but PRA 15 and 16 have not been working correctly for long spectra. I'm using a windows 10 64 bit desktop set to never sleep for my gamma spectrum things. For whatever reason, PRA stops collecting data before the acquisition limits are reached. I had been collecting data from a sample of volcanic ash, trying to get 2 days worth of data, but it quit 2 hours early. When I tried to collect a background for the actual time the ash was measured, it quit 6 hours early. The program isn't freezing, it still responds, and the drop down menus are still greyed out as if it were still collecting data but none of the displays change. You have to hit Stop before you can do anything. I am at a loss for what is causing this. My entire system is on an uninterruptible power supply, and the computer never sleeps.

If anyone has suggestions, please let me know.

Thanks
Geoff Van Horn

Anchorage and Deadhorse Alaska

User avatar
Steven Sesselmann
Posts: 661
Joined: 27 Apr 2015, 11:40
Location: Sydney
Contact:

Re: PRA 16.0.0.2 problems

Post by Steven Sesselmann » 19 Jul 2017, 11:58

Geoff,

I have brought this post to Marek's attention.
Steven Sesselmann | Sydney | Australia | gammaspectacular.com | groundpotential.org | beejewel.com.au |

User avatar
Steven Sesselmann
Posts: 661
Joined: 27 Apr 2015, 11:40
Location: Sydney
Contact:

Re: PRA 16.0.0.2 problems

Post by Steven Sesselmann » 19 Jul 2017, 13:07

As always Marek is super responsive, and I received this reply within hours..
Hi Steven.

I know a problem with stopping PRA before it reaches limits. It is caused by problem with sound interface driver which is not responding to the data request from PRA. When PRA is waiting for the data it does not send any new request and it stays like this forever. It is happening most frequently when Windows is communicating with Microsoft to get updates or send another information. Unfortunately sound interface does not have very high privilege level.

To make a work around to solve the problem I wrote a new version of PRA 16.0.1.0 which has a new feature, it is possible to stop data acquisition and start it again without loosing already collected data. This will produce some timing inconsistency, but in case of collecting spectra it is fine. Additionally you can use this method to extend any existing file with a new data. The new version of PRA is already on line.
Information of date and time when data acquisition started and when was finished is automatically written to the Settings->Data Acquisition and Analysis->Comments and will be saved with the data.

Best regards,

Marek
Steven Sesselmann | Sydney | Australia | gammaspectacular.com | groundpotential.org | beejewel.com.au |

User avatar
Geoff
Posts: 98
Joined: 01 May 2015, 12:21
Location: Marathon County, Wisconsin
Contact:

Re: PRA 16.0.0.2 problems

Post by Geoff » 19 Jul 2017, 14:05

Awesome! Thank you Steve and Marek! I'll get that installed tonight and start a new spectrum.
Geoff Van Horn

Anchorage and Deadhorse Alaska

User avatar
Steven Sesselmann
Posts: 661
Joined: 27 Apr 2015, 11:40
Location: Sydney
Contact:

Re: PRA 16.0.0.2 problems

Post by Steven Sesselmann » 20 Jul 2017, 10:10

Message from marek:
Hi Steven,
I found a small bug in yesterday's version of PRA and fixed it. Also on my site the link to 64 bit installer was wrong. Please reload PRA and relay the news.
Best regards,
Marek
Steven Sesselmann | Sydney | Australia | gammaspectacular.com | groundpotential.org | beejewel.com.au |

User avatar
Geoff
Posts: 98
Joined: 01 May 2015, 12:21
Location: Marathon County, Wisconsin
Contact:

Re: PRA 16.0.0.2 problems

Post by Geoff » 20 Jul 2017, 12:36

Whoops! No problem, I noticed the link error so I went with the 32 bit. I'll go ahead and download the update and start again.
Geoff Van Horn

Anchorage and Deadhorse Alaska

User avatar
Geoff
Posts: 98
Joined: 01 May 2015, 12:21
Location: Marathon County, Wisconsin
Contact:

Re: PRA 16.0.0.2 problems

Post by Geoff » 20 Jul 2017, 12:43

Hmmm. Seems to be a new problem, Google Chrome blocks the download and flags it as malware/virus.
Geoff Van Horn

Anchorage and Deadhorse Alaska

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest