Page 2 of 4

Re: GEIGERBOT for Iphone

Posted: 14 Jun 2019, 20:16
by Hendrik Vingerhoet
I had a try on this with some more devices.
Seems to be related to the IOS version:
Ipad Mini 2 -> Works on ios 11
Ipad Mini 4 -> Ios 12.2 -> App not under microphone permissions and also does not ask for it
Iphone X -> Ios 12.3.1-> with lightning to jack -> App not under microphone permissions and also does not ask for it
Iphone 5 -> Ios 11. something (will check later) -> Works with microphone jack and lightning to jackplug

Seems like something changed after ios version 12.

@Steven, did you hear back from Nick Dolezal yet ? I sent him an email regarding this issue some time ago but never got a response from him.
I checked the safecast app as well but it does the exact same thing as Geigerbot
Would be awesome to hear something from Nick, even if it is just a i wont update this anymore.
If he wont update it anymore and he allows it i could try building a new version if he releases the source code ( i am a webdeveloper but have made apps before )

Re: GEIGERBOT for Iphone

Posted: 28 Jun 2019, 13:35
by Conor Whyte
I just built a cable for my Iphone 6s + that used a 980 ohm resistor across the top and second ring on the TRRS connector. 4 banded jack.
I have been able to successfully trigger a headphones signal with down to as low as 550 ohms... I also wouldn't go beyond 1Kohm as values larger than this seemed to not reliably trigger the input.

The signal takes about 5-10secs to show up and switch the iPhone over to "headphone input."

Today I was also to get Geigerbot to work beautifully and captured a NORM spectrum from a very pure/ warm sample of Uraninite.
Does about 80KCPM with the scintillation detector.

I just got a spare lightning jack and will test it tomorrow to see if I can trigger the input.

tested several different isotopes, Mn54, Cs137, Ra226, Th232, K40 and Am241... each time I was able to get them to show up without issues.

I am running the latest iOS.

IT is safe to say that Safecast is a completely dead app. I could not trigger it with the cable I built at all. I tried several combinations... no cigar.

Re: GEIGERBOT for Iphone

Posted: 28 Jun 2019, 15:55
by Steven Sesselmann

This is interesting information, we have been recommending 1K resistor.

Let me try and replicate your experiment on the weekend.


Re: GEIGERBOT for Iphone

Posted: 28 Jun 2019, 16:49
by Conor Whyte
On second though it might have been the resistor.... 1Kohm seems to work fine.
I just tried a 2Kohm for fun... I thought at first it wasn't switching. I'm wrong. It does work.
I can also confirm that 550ohm - 600ohms also triggers the headphone input as well.

Different story with the lightning adapter. Not reliably switch at all.

Re: GEIGERBOT for Iphone

Posted: 29 Jun 2019, 08:59
by Steven Sesselmann

I just installed Geigerbot on my iPad, and it's a no go, the app displays some red text "Microphone Permission Denied, No Input Available"

When I go to the iPad settings under Privacy >> Microphone the Geigerbot app is not on the list.

I have another app called Atom which also uses the mic input, it's listed in the privacy/mic settings and it works fine.

Although the Geigerbot app functioned very well, I think there is a lot of room for improvement on the screen design, especially on the iPad. Looks like Nick never put too much effort into iPad version.


Re: GEIGERBOT for Iphone

Posted: 29 Jun 2019, 11:55
by Conor Whyte
What iPad version do you have? I tried the lightning adapter with the line today both with an iPhone 6s+ and an iPad pro 12.9" 2016 version and it worked fine. You've got to enable the input permission through the settings menu, as by default they are disabled.

and while there was no message suggesting a switching of inputs with the lightning adapter, Geigerbot just started working.
the app should be started first!
The input with the adapter is noticeably quieter and takes longer for the spectrum to appear.

Using a Zoom H6n to record incoming pulses from the driver GS USB PRO as a 96Khz 24bit WAV and then dropping them directly in PRA22.
10A/hr Battery pack for portable use.

Lightning adapter below with modified mono cable.
Spectra obtained with Geiger bot using an iPhone 6s+

Re: GEIGERBOT for Iphone

Posted: 29 Jun 2019, 16:44
by Steven Sesselmann

In typical apple weirdness, my settings window seems to be missing the Mic setting.

My iPad Mini 2 software version is 12.3.1



Re: GEIGERBOT for Iphone

Posted: 30 Jun 2019, 01:25
by Conor Whyte
Seems that the newer hardware works differently, especially with iPad.
The microphone may be in a different spot, and is now under the return button in the bottom right corner.

Also, Check to see if you currently have Settings > General > Restrictions > Microphone (under the 'privacy' heading) set to 'don't allow changes' - if you do then change it to 'allow changes.

What happens when you connect the headphone lightning adapter when the app is running? can you use a pair of apple headphones to record audio at all?

Re: GEIGERBOT for Iphone

Posted: 30 Jun 2019, 09:08
by Hendrik Vingerhoet
Conor, on what ios version are you doing this, i guess 11 or earlyer since the whole settings menu changed :) ?
iOs 12 introduced a few changes to the microphone permissions which i think is the reason this does not work anymore since version 12.
Apple now requires developers to add a text to the main plist file stating why you want microphone permissions, if it is not there you simply dont get the question and cant enable it as far as i have seen here as a developer.
The screenshots are on Ios 12, i have an old iphone on 11 which is working fine, but my two ipads and iphone x on 12 simply dont show the microphone permissions.

If you are on ios 12, did you upgrade while the geigerbot app was already on there? Because permissions would propably be rememberd then, in my case its all fresh ios 12 installs

Re: GEIGERBOT for Iphone

Posted: 30 Jun 2019, 09:28
by Conor Whyte
I am using iOS 12.3.1, the latest iOS update for my iPhone 6s+.
I am suspecting that the app does not have the permissions to access the internal ADC for the newer hardware... > I don't have a newer iPad or iPhone7 or up to test my theory.
Have you tried using the lightning adapter with a pair of headphones to see if you can trigger the input?